Няколко проблема със софтуеер и с драйвери

Въпроси свързани с използването на УСУ

Няколко проблема със софтуеер и с драйвери

Мнениеот Зеленичък » 03 Фев 2016, 21:44

Привет на всички! Реших отново да пробвам Линукс (от време на време опитвам да мина на Линукс). Конфигуразията ми е:

МВ: Gigabyte GA-EP35-DS3
Чип: Intel Bearlake P35
ЦПУ: DualCore Intel Pentium E6500, 2933 MHz (11 x 267)
Видео - вграденото интелско
Звук на дъното Realtek ALC889A @ Intel 82801IB ICH9 - High Definition Audio Controller [A-2]
Звук на PCI Creative SB Live! 24-bit (SB0410) Sound Card
HDD Хитачи 1ТБт разделен на 2х500

Не е първа младост компютърчето, но засега ми върши идеална работа. Успява дори да ми пусне 3D 1920х1080 на телевизора със звук 5+1 и то без изобщо да засича - та затова и не планирам засега да го сменям.

Този път срещнах следните проблеми с които неуспях да се справя (търсих решения в този форум защото инасталирах УСУ 9.1 десктоп 32bit):
Звукът ми и на двете звукови карти е ужасен. На вградената "свисти" и "жужи", на на креатива "пука" На всичко отгоре на креатива изобщо се чува само единият канал - левият. Да уточня, че на креатива са ми слушалките, а на реалтек- а ми е системата 5+1 (тя пък работи само двата предни високоговорителя. Задни, център и буфер ги няма. Освен това аз искам да ги разменя - креатива да ми е по подразбиране включен (сега е обратното. Опитах през "настройване на ѝвук и видео - контролен модул на КДЕ", опитах и през "Алса" (мисля че беше) - няма резултат. Отворих Драйвър мениджър- а (дали правилно го написах - незнам английски) - нищо няма в него. Празен. Отворих Информационен център и виждам че креатива е погрешно разпознат като някаква друга карта, а и реалтек- а също. Реших, че е добре първо да обновя системата, може да има нещо фикснато. Пак тук прочетох, че има проблем с MUON - да се ползва Синаптик. Стартирам Синаптик, вкарвам си великата парола 1 и получавам съобщение:
"Възникна грешка. Налице са следните детайли: "Е: Процесът dpkg е беше прекъснат. Проблемът трябва да се коригира чрез ръчно изпълнение на „sudo dpkg --configure -a“.
E: _cache->open() failed, please report." Следва бутон "Затвори" и толкова!
Е, казвам си - Като нямам боб ще ядем леща! Пускам MUON Той поне стартира, но 3 часа чака за някакъв "конфигурационен файл", и още щеше да си чака, но на мен ми се изчака чакалото и го праснах.
Пропуснах да отбележа, че докато инсталирах ОС всичко мина успешно. Невъзникнаха никакви грешки. Проблем с хардуеера няма - рестартирам в Win XP и там всичко е 6!
Ако някой има желание - всяка помощ ще ми е добре дошла. Само дано не се налага да пиша пак разни заклинания в конзола. 21 век сме все пак :)
Зеленичък
Старши член
Старши член
 
Мнения: 49
Регистриран на: 12 Яну 2011, 23:39

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот stancho » 03 Фев 2016, 22:29

Стартирам Синаптик, вкарвам си великата парола 1 и получавам съобщение:
"Възникна грешка. Налице са следните детайли: "Е: Процесът dpkg е беше прекъснат. Проблемът трябва да се коригира чрез ръчно изпълнение на „sudo dpkg --configure -a“.


Като за начало трябва да си оправиш пакетната система. Какво се случва след като изпълниш в терминала:
Код: Избери целия код
sudo dpkg --configure -a


После пусни информацията за звуковите карти които ти засича системата:
Код: Избери целия код
lspci -v

Код: Избери целия код
cat /proc/asound/cards

Код: Избери целия код
aplay --list-devices
Аватар
stancho
Старши член
Старши член
 
Мнения: 72
Регистриран на: 08 Юли 2012, 23:57

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот Зеленичък » 03 Фев 2016, 22:43

a@a-G41M-ES2H:~$ sudo dpkg --configure -a
[sudo] password for a:
no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory
Инсталиране на menu (2.1.46ubuntu1) ...
Инсталиране на base-files (7.2ubuntu5.3) ...

Configuration file '/etc/issue'
==> Modified (by you or by a script) since installation.
==> Доставчика на пакета достави надградена версия.
What would you like to do about it ? Your options are:
Y or I : install the package maintainer's version
N or O : keep your currently-installed version
D : show the differences between the versions
Z : start a shell to examine the situation
Подразбиращато действие е да се задържи вашата текуща версия.
*** issue (Y/I/N/O/D/Z) [по подразбиране=N]
Зеленичък
Старши член
Старши член
 
Мнения: 49
Регистриран на: 12 Яну 2011, 23:39

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот Зеленичък » 03 Фев 2016, 22:45

a@a-G41M-ES2H:~$ lspci -v
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
Subsystem: Gigabyte Technology Co., Ltd Device 5000
Flags: bus master, fast devsel, latency 0
Capabilities: <access denied>
Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
Subsystem: Gigabyte Technology Co., Ltd Device d000
Flags: bus master, fast devsel, latency 0, IRQ 40
Memory at fd800000 (64-bit, non-prefetchable) [size=4M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
I/O ports at ff00 [size=8]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915

00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
Subsystem: Gigabyte Technology Co., Ltd Device d000
Flags: bus master, fast devsel, latency 0
Memory at fde00000 (64-bit, non-prefetchable) [size=1M]
Capabilities: <access denied>

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
Subsystem: Gigabyte Technology Co., Ltd GA-D525TUD (Realtek ALC887)
Flags: bus master, fast devsel, latency 0, IRQ 41
Memory at fdff8000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel

00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01) (prog-if 00 [UHCI])
Subsystem: Gigabyte Technology Co., Ltd GA-D525TUD
Flags: bus master, medium devsel, latency 0, IRQ 23
I/O ports at fe00 [size=32]
Kernel driver in use: uhci_hcd

00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01) (prog-if 00 [UHCI])
Subsystem: Gigabyte Technology Co., Ltd GA-D525TUD
Flags: bus master, medium devsel, latency 0, IRQ 19
I/O ports at fd00 [size=32]
Kernel driver in use: uhci_hcd

00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01) (prog-if 00 [UHCI])
Subsystem: Gigabyte Technology Co., Ltd GA-D525TUD
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at fc00 [size=32]
Kernel driver in use: uhci_hcd

00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01) (prog-if 00 [UHCI])
Subsystem: Gigabyte Technology Co., Ltd GA-D525TUD
Flags: bus master, medium devsel, latency 0, IRQ 16
I/O ports at fb00 [size=32]
Kernel driver in use: uhci_hcd

00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01) (prog-if 20 [EHCI])
Subsystem: Gigabyte Technology Co., Ltd GA-D525TUD
Flags: bus master, medium devsel, latency 0, IRQ 23
Memory at fdfff000 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ehci-pci

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1) (prog-if 01 [Subtractive decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
I/O behind bridge: 0000d000-0000dfff
Memory behind bridge: fdd00000-fddfffff
Prefetchable memory behind bridge: 00000000b9d00000-00000000b9dfffff
Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
Subsystem: Gigabyte Technology Co., Ltd Device 5001
Flags: bus master, medium devsel, latency 0
Capabilities: <access denied>
Kernel driver in use: lpc_ich

00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 01) (prog-if 8a [Master SecP PriP])
Subsystem: Gigabyte Technology Co., Ltd Device b002
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 19
I/O ports at 01f0 [size=8]
I/O ports at 03f4
I/O ports at 0170 [size=8]
I/O ports at 0374
I/O ports at f800 [size=16]
Capabilities: <access denied>
Kernel driver in use: ata_piix

00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
Subsystem: Gigabyte Technology Co., Ltd GA-8I945PG-RH/GA-D525TUD Mainboard
Flags: medium devsel, IRQ 11
I/O ports at 0500 [size=32]

01:01.0 Multimedia audio controller: Creative Labs CA0106 Soundblaster
Subsystem: Creative Labs SB0410 SBLive! 24-bit
Flags: bus master, medium devsel, latency 32, IRQ 19
I/O ports at df00 [size=32]
Capabilities: <access denied>
Kernel driver in use: snd_ca0106

01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)
Subsystem: Gigabyte Technology Co., Ltd GA-MA69G-S3H Motherboard
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 21
I/O ports at dc00 [size=256]
Memory at fddff000 (32-bit, non-prefetchable) [size=256]
[virtual] Expansion ROM at b9d00000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: r8169
Зеленичък
Старши член
Старши член
 
Мнения: 49
Регистриран на: 12 Яну 2011, 23:39

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот Зеленичък » 03 Фев 2016, 22:46

a@a-G41M-ES2H:~$ cat /proc/asound/cards
0 [CA0106 ]: CA0106 - CA0106
Live! 7.1 24bit [SB0410] at 0xdf00 irq 19
1 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xfdff8000 irq 41
Зеленичък
Старши член
Старши член
 
Мнения: 49
Регистриран на: 12 Яну 2011, 23:39

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот Зеленичък » 03 Фев 2016, 22:47

a@a-G41M-ES2H:~$ aplay --list-devices
**** Списък на PLAYBACK хардуерни устройства ****
карта 0: CA0106 [CA0106], устройство 0: ca0106 [CA0106]
Подустройства: 1/1
Подустройство #0: subdevice #0
карта 0: CA0106 [CA0106], устройство 1: ca0106 [CA0106]
Подустройства: 1/1
Подустройство #0: subdevice #0
карта 0: CA0106 [CA0106], устройство 2: ca0106 [CA0106]
Подустройства: 1/1
Подустройство #0: subdevice #0
карта 0: CA0106 [CA0106], устройство 3: ca0106 [CA0106]
Подустройства: 1/1
Подустройство #0: subdevice #0
карта 1: Intel [HDA Intel], устройство 0: ALC887 Analog [ALC887 Analog]
Подустройства: 1/1
Подустройство #0: subdevice #0
карта 1: Intel [HDA Intel], устройство 1: ALC887 Digital [ALC887 Digital]
Подустройства: 1/1
Подустройство #0: subdevice #0
карта 1: Intel [HDA Intel], устройство 3: HDMI 0 [HDMI 0]
Подустройства: 1/1
Подустройство #0: subdevice #0
Зеленичък
Старши член
Старши член
 
Мнения: 49
Регистриран на: 12 Яну 2011, 23:39

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот Зеленичък » 03 Фев 2016, 22:47

... каквото и да означава това....
Зеленичък
Старши член
Старши член
 
Мнения: 49
Регистриран на: 12 Яну 2011, 23:39

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот Зеленичък » 03 Фев 2016, 22:56

Всъщност аз като си потбирах дистрибуция очаквах че тоя пакетен мениджър си е наред. Неочаквах че аз ще се налага да го оправям (господ да му е на помощ в този случай) Четох упътването на това УСУ - Пишеше "Стартираш и ... Всичко ОК" Дали няма някоя дистрибуция която наистина да няма нужда от такива настройки?
Зеленичък
Старши член
Старши член
 
Мнения: 49
Регистриран на: 12 Яну 2011, 23:39

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот stancho » 03 Фев 2016, 23:00

Зеленичък написа:a@a-G41M-ES2H:~$ sudo dpkg --configure -a
[sudo] password for a:
no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory
Инсталиране на menu (2.1.46ubuntu1) ...
Инсталиране на base-files (7.2ubuntu5.3) ...

Configuration file '/etc/issue'
==> Modified (by you or by a script) since installation.
==> Доставчика на пакета достави надградена версия.
What would you like to do about it ? Your options are:
Y or I : install the package maintainer's version
N or O : keep your currently-installed version
D : show the differences between the versions
Z : start a shell to examine the situation
Подразбиращато действие е да се задържи вашата текуща версия.
*** issue (Y/I/N/O/D/Z) [по подразбиране=N]


Изпълни командата още веднъж и ако се появят пак тези въпроси, просто удари по един Enter за да се довърши процеса.
След това Synaptic би трябвало да се стартира нормално и пакетната система да се оправи.
Това се получава когато прекъсне ъпгрейд или инсталация поради някаква причина. Нищо страшно ;) случва се по някога.

За другото не знам колко ще съм от полза ако ми дойде нещо наум ще пиша. Поне вече другите съфорумници имат някаква отправна точка.
Аватар
stancho
Старши член
Старши член
 
Мнения: 72
Регистриран на: 08 Юли 2012, 23:57

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот Зеленичък » 04 Фев 2016, 08:58

Благодаря ти stancho за отделеното време и за желанието да помогнеш. Довечера като се прибера обезателно ще се възползвам от съвета ти - Снощи ми "падна батерията" и си легнах по- раничко. Чак тази сутрин прочетох отговора ти. Още веднъж - Благодаря!
Зеленичък
Старши член
Старши член
 
Мнения: 49
Регистриран на: 12 Яну 2011, 23:39

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот малин » 04 Фев 2016, 11:49

Зеленичък написа:Всъщност аз като си потбирах дистрибуция очаквах че тоя пакетен мениджър си е наред. Неочаквах че аз ще се налага да го оправям (господ да му е на помощ в този случай) Четох упътването на това УСУ - Пишеше "Стартираш и ... Всичко ОК" Дали няма някоя дистрибуция която наистина да няма нужда от такива настройки?

:) Виж кога е пусната версията на ОС която ползваш, от тогава толкова вода е изтекло... И ако не искаш да променяш навиците си от другата ОС - по-добре не започвай изобщо. Изчакай още някоя-друга година когато нещата ще се "слегнат" окончателно.
Аватар
малин
Заклет фен
 
Мнения: 913
Регистриран на: 08 Фев 2012, 15:41

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот stancho » 04 Фев 2016, 12:33

Сега... доколкото разбирам към вградената карта си вързал 5.1 системата и там се чува "свистене и жужене". Като усилваш/намаляш звука от компютъра дали и това "свистене/жужене" се увеличава? По какъв начин си осъществил връзката, с какъв кабел, през какви входове и изходи? Ако ползваш слушалки има ли го пак свистенто? Можеш ли да дадеш и някаква информация за 5.1 системата?
Дай няколко скрийншота от alsamixer-a и за двете звукови карти. В терминал изпълняваш:
Код: Избери целия код
alsamixer

Разпъни терминала на цял екран преди да направиш скрийновете за да се хванат максимум от контролите.
Със стрелките наляво/надясно навигираш между каналите, с нагоре/надолу усилваш/намаляш даден канал, с F6 избираш едната или другата карта, ESC - изход от програмата.

[offtopic]
Kато си се се хванал си линукс няма да се плашиш от конзолата. Приеми я като допълнителна екстра към графичната среда. А тези "заклинания" които се пишат в нея изобщо не са сложни, а и аз не бих ги нарекъл така :). Само за пример ще посоча, че в 21-ви век в другата ОС се появи едно нещо наречено PowerShell. Е там вече нещата изглеждат като "заклинания" :D.
Аватар
stancho
Старши член
Старши член
 
Мнения: 72
Регистриран на: 08 Юли 2012, 23:57

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот lokster » 04 Фев 2016, 16:10

От звуковите настройки на КДЕ (десен бутон върху иконката за звука горе до часовника -> Звукови настройки) можеш да избереш като колко канална да работи всяка звукова карта.
Прави се от "Настройки на звуковия хардуер". Там в "Звукова карта" избираш картата, а в "Профил" избираш конфигурацията:
audio-settings.jpg

Накрая щракаш "Прилагане".

Относно жуженето и т.н. - първо се увери че е от звуковата карта. Пробвай със слушалки дали го има.
Ако го няма - провери си канелите :)
Ако го има - провери дали случайно звуковата карта не се опитва да прихваща и възпроизвежда сигнал от микрофон/line in - пробвай в alsamixer да избереш картата с F6, след това с F4 избери да се покажат каналите за прихващане. И пробвай един по един да ги намаляш за да видиш променя ли се нещо. Ако няма промяна - върни си ги както са.
Ако има - изпълни "sudo alsactl store" и би трябвало да си готов.

Ако нищо нещата които сме споменали не помага, опитай и с по-ново ядро - примерно инсталирай linux-generic-lts-wily и рестартирай.
Честно казано трябва да си някакъв много голям "късметлия" за да имаш проблеми и с двете звукови карти. Пусни тото :)
"My mind is going. I can feel it. There is no question about it. I can feel it. I can feel it. I’m afraid."
Аватар
lokster
Администратор
Администратор
 
Мнения: 3452
Регистриран на: 11 Май 2008, 12:26
Местоположение: Видин, България

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот Зеленичък » 04 Фев 2016, 16:49

Привет! Аз по- горе описах че пробвах да го оправя от зв. настройки в КДЕ и alsamixer, защото доста се порових преди да викна тук "F1" ;-) С хардуеера, кабелите, звуковата система и слушалките няма никакъв технически проблем, защото като рестартирам в ХР- то всичко си работи нормално. А тото наистина ще пусна след около час - Благодаря за напомнянето :-)
Зеленичък
Старши член
Старши член
 
Мнения: 49
Регистриран на: 12 Яну 2011, 23:39

Re: Няколко проблема със софтуеер и с драйвери

Мнениеот stancho » 04 Фев 2016, 18:46

Дай все пак информацията която ти поисках в предния пост. Направи и няколко скрийншота на "Настройки на звуковия хардуер".
Аватар
stancho
Старши член
Старши член
 
Мнения: 72
Регистриран на: 08 Юли 2012, 23:57

Следваща

Назад към Въпроси / Проблеми

Кой е на линия

Потребители разглеждащи този форум: 0 регистрирани и 2 госта

cron