Проблеми с WEB-камери под Линукс

Въпроси свързани с използването на УСУ

Re: Проблеми с WEB-камери под Линукс

Мнениеот reger » 10 Юни 2014, 22:59

Мерси за линковете!
Решението на проблема с обърнатия образ (WEB камери CNF7129) за версии на Убунту базирани дистрибуции за 12.04 е това:

This is how I fix the webcam upside/down problem now, ubuntu 12.04.
I use skype as an example!

Some webcams works perfect with Cheese and other webcam applications, but in Skype you may have a green screen, no picture at all or the picture is upside down!
If you have webcam issues with skype, fix this by doing this:

Код: Избери целия код
echo -e '#!/bin/bash \n LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype' | sudo tee /usr/local/bin/skype
sudo chmod a+x /usr/local/bin/skype


NOTE1: Skype is a 32bit program so i386 in the above fix is correct for skype since it uses 32bit libraries, even if you use 64bit version of Ubuntu!

NOTE2: If the program you want to manipulate is 64bit you have to use /usr/lib/x86_64-linux-gnu/libv4l/ instead of /usr/lib/i386-linux-gnu/libv4l/

If the above fix does not work, try using this instead

Код: Избери целия код
echo -e '#!/bin/bash \n LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l2convert.so /usr/bin/skype' | sudo tee /usr/local/bin/skype

източник
reger
Зарибен
Зарибен
 
Мнения: 15
Регистриран на: 07 Апр 2011, 22:01

Проблем със Скайп и вградена WEB камера на лаптоп Асус K50

Мнениеот reger » 12 Юни 2014, 18:22

reger написа:Проблемът е със Скайп и вградената WEB камера на лаптоп Асус K50IJ.
Операционната система е УСУ 9, но положението е същото и с други Убунту базирани дистрибуции (пробвано с УСУ 8, УСУ 7, Хубунту 12.04, Хубунту 14.04)

Камерата работи, но ... в Скайп и само в Скайп образът на картината е обърнат "с главата надолу" - в Brosix и Cheese няма проблем.
................


Така, оказва се че горното решение за обърнатия образ работи за 12.04, но не и за 14.04 в това число и за УСУ 9.

Продължавам да търся, но засега не намирам нещо, което да свърши работа.
Изглежда този проблем обхваща сравнително голям брой серии лапопи на Асус и все още не разбирам защо не е направено нищо по въпроса от общността. За 10.04 решението е едно, за 12.04 друго и вероятно за 14.04 ще е нещо различно.

Все пак успея ли да намеря решение ще пусна "рецептата" тук. :call:

Забележка:
v4l1compat.so и v4l2convert.so за 64bit 14.04 са в друга директория и кода по-горе ще изглежда така:

Код: Избери целия код
echo -e '#!/bin/bash \n LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype' | sudo tee /usr/local/bin/skype
sudo chmod a+x /usr/local/bin/skype

Код: Избери целия код
echo -e '#!/bin/bash \n LD_PRELOAD=/usr/lib/x86_64-linux-gnu/libv4l/v4l2convert.so /usr/bin/skype' | sudo tee /usr/local/bin/skype
sudo chmod a+x /usr/local/bin/skype

но за съжаление, както вече писах, това вече не работи за 14.04
reger
Зарибен
Зарибен
 
Мнения: 15
Регистриран на: 07 Апр 2011, 22:01

Предишна

Назад към Въпроси / Проблеми

Кой е на линия

Потребители разглеждащи този форум: 0 регистрирани и 1 госта

cron